「エントリーカード全体をリンク化」で外部カードのタイトルが外に追い出される

Simplicityの特徴 フォーラム Simplicity2に関する話題何でも 「エントリーカード全体をリンク化」で外部カードのタイトルが外に追い出される

  • このトピックには29件の返信、2人の参加者があり、最後にsainoaにより3年、 6ヶ月前に更新されました。
29件の返信スレッドを表示中
  • 投稿者
    投稿
    • #44091
      sainoa
      ゲスト

      2.2.3bを入れ、「エントリーカード全体をリンク化」を有効にしてみたところ、
      外部サイトのカードで、記事タイトルが枠外に追い出されてしまいました。

      このページの、上から三つのカードがそうです。

      http://wordpress.sainoa.com/archives/97

      また、wp-simplicity.comのカードは、タイトルが取得できないのか、
      This page is error.になってしまっています(これは、2.2.2のときもそうでした)。

      また、上記ページの四つ目は、wp-simplicity.comの外部カードですが、
      タイトルは追い出されてはいません。errorは同様ですが。

      他にもいくつか見てみました。

      こちらのページの外部サイトは、タイトルが正しい位置です。

      http://wordpress.sainoa.com/archives/318

      こちらは、アイキャッチに対してタイトルが下にずれ、かつ、枠からはみ出しているものと、
      タイトルが枠外に追い出されているものが見られます。

      http://wordpress.sainoa.com/archives/109

      nelog.jpは正常にカード化されています。

      http://wordpress.sainoa.com/archives/127

      以上、色々なパターンが見られたことを報告しておきます。

    • #44092
      sainoa
      ゲスト

      すみません。補足です。

      Webブラザを変えたところ、見え方がわかりました。
      先に書いたものは、Chromeで見た場合です。
      Firefoxで見たら、最初のページでは、タイトルの追い出しはありませんでした。

      ですが、こちらのページでは、先の報告と同様、
      Firefoxでもタイトルのずれ、追い出しが確認できました。

      http://wordpress.sainoa.com/archives/109

      Webブラウザなど、利用者の環境にも左右されるようです。

    • #44093
      Hidekichi
      ゲスト

      タイトルがはみ出すと言われる部分は、.hover-cardが問題っぽいです。
      修正方法は2つあり、

      .hover-cardのwidth: 500pxを解除するか、display: blockを解除するかです。両方解除しても修正できます。つまりはblockでwidthが500であるとマズイということですね。

      これ(.hover-card)が何をしているのかはまだ試してないので僕は知りませんが、例えば

      .blog-card .hover-card {
        display: unset;
      }

      とかを子テーマstyle.css等に書いておけば少なくともはみ出すのは修正できるのではなかろうかと。

      http://wordpress.sainoa.com/archives/97 ← このリンクのブログカードでタイトル部分がはみ出ないのは、.hover-cardが適用されてないからかと思います。
      http://wordpress.sainoa.com/archives/127 ← こちらも同様に.hover-cardが適用されてないのではみ出してないものと思われます。

    • #44097
      わいひらわいひら
      キーマスター

      こちらの、テスト環境では、おかしな表示になっているURLのブログカードも問題なく表示されているようです。
      http://simplicity.wp.xdomain.jp/post-2201/
      httpでも、httpsのSimplicityサイトどちらでも問題なく取得できているようです。

      以下でも書いたのですが、おそらくキャッシュ関係の何かが影響しているのではないかと思います。

      ブラウザキャッシュ、mod_pagespeedキャッシュ、CDNキャッシュが残っている場合は変更した部分のスタイルが適用されない
      Simplicityのレイアウトカスタマイズにある「エントリーカード全体をリンク化」機能の説明

      あと、できれば以下のページに関しては、生原稿(テキストエディターの内容を)をこのトピックに貼り付けていただければと思います。
      http://wordpress.sainoa.com/archives/109
      投稿管理画面のテキストエディターから、原稿をコピーして、入力欄に貼り付けて、以下に掲載されているコードの貼り付け方でコード表示化していただけると助かります。
      https://wp-simplicity.com/suport/topic/first-time/
      何かしら、文章の書き方で、そういった不具合が出ている可能性もあるので。よかったよろしくお願いします。

    • #44113
      sainoa
      ゲスト

      アドバイス、ありがとございます。

      まず、.hover-card に関してですが、ご提示頂いた三行を子テーマのstyle.cssに書き加えたところ、期待通り、記事タイトルがカード外に追い出されることはなくなりました。それを確認後、現在は元に戻してあります。

      それから、キャッシュに関しては、私も考えました。あのサイトは、Z.com for WordPressを使用しております。サーバサイドでキャッシュを持っているようですので、そのキャッシュを管理画面から削除してみました。ですが、変化はありませんでした。それで、昨夜、あの報告をいたしました。

      ブラウザキャッシュにも削除しました。手順は、こちらのページの一番上のものです。

      http://nelog.jp/clear-chrome-browser-cache

      Firefoxでも設定画面からキャッシュの削除を行ってみましたが、効果は見られませんでした。

      mod_pagespeedは、使用しているサーバでは、おそらく、その機能を持っていないと思います。

      CDNキャッシュについては、対処方法が分かりません(使用しているのかも分かりません)。

      以下、当該ページの原稿のコピーです。

      作ったサイトは、Googleにインデックスしてもらわないと始まりません。Bingもありますけど、まぁ、そちらはとりあえず置いておいて。
      
      ということで、
      
      PubSubHubbub
      
      という仕組みの導入から行きましょう。
      
      なんだか、文字化けか、呪文のようですよね。パブサブハブバブ、もしくは、パブサブハバブと読むようです。カタカナにしても呪文のようです。略称もあって、PuSH(プッシュ)とも呼ぶようです。
      
      これは、Hubという仕組みに、自分の更新情報を通知します。更新情報を知りたい者は、各ブログを見に行くのではなく、そのHubに問い合せれば良いわけです。ここに情報が集まっていますから。
      
      Googleは更新情報をHubからも取得するようになっています。そのココロは、Googleはリアルタイム検索を実現したいからです。
      
      <a href="http://www.suzukikenichi.com/blog/google-index-to-go-real-time-by-using-pubsubhubbub/" target="_blank">Google、PubSubHubbubで真のリアルタイムインデックスを実現</a>
      
      詳しいことは上記のサイトをご覧いただくとして、要するに、自分のサイトの更新情報は、PubSubHubbubの仕組みでHubに送れば良いわけです。
      
      この目的として、WordPressでは二つのプラグインがあるようです。
      
      PubSubHubbub
      http://netaone.com/wp/pubsubhubbub/
      
      PuSHPress
      http://www.barnetshenkinbridge.com/wordpress/750/
      
      基本的には、どちらも、インストールして有効化するだけです。特に設定はありません(PubSubHubbubは設定もできますが、標準のままで大丈夫です)。これだけで、(原理的には)瞬時にインデックスしてもらえるのですから、WordPressを使っているなら、やらない手はありません。両方を入れる必要はありません。どちらか一方でOKです。私は、PubSubHubbubの方を使っています。特段の理由はないのですが…。
      
      http://wordpress.sainoa.com/archives/112

      よろしくお願いします。

    • #44114
      sainoa
      ゲスト

      ちょこちょこすみません。一点、書き漏れです。
      念のため、プラグインをすべて停止してみましたが、タイトルは枠外に追い出されたままでした。

    • #44137
      わいひらわいひら
      キーマスター

      おそらく以下のような部分で、改行(<br>)が入ってしまうため正常動作しないように思います。

      PubSubHubbub
      http://netaone.com/wp/pubsubhubbub/

      以下のように変更してみてください。

      PubSubHubbub
      
      http://netaone.com/wp/pubsubhubbub/

      前者は、通常ならブログカードを表示しないようにしないといけなかったのですが、その書き込みは想定していませんでした。
      前者をブログカード表示しないようにしたものは以下にアップしてみました。
      https://wp-simplicity.com/wp-content/uploads/2016/08/simplicity2.zip
      うまくいくようであれば、次のバージョンで適用したいと思います。

      • この返信は3年、 6ヶ月前にわいひらわいひらが編集しました。理由: 内容の修正
    • #44140
      sainoa
      ゲスト

      ありがとうございます。私の使い方の間違いだったんですね。正しい記法(前後に空行)にしたところ、カードの表示崩れはなくなりました。

      その後、修正版に入れ替えて確認しました。動作確認ができるよう、以下の二種の記述にしてみました。

      PubSubHubbub
      http://netaone.com/wp/pubsubhubbub/
      
      PuSHPress
      
      http://www.barnetshenkinbridge.com/wordpress/750/

      結果は、期待通り、前者はカードにならず、後者は崩れなく表示されています。

      http://wordpress.sainoa.com/archives/109

      また、こちらのページ、

      http://wordpress.sainoa.com/archives/97

      記法を修正し、表示の崩れはなくなりましたが、Simplicityのページだけ「This page is error.」になってしまうのは変りません。

    • #44142
      わいひらわいひら
      キーマスター

      「This page is error.」と出るのは、今回のバージョンアップとは別の問題で出ています。
      おそらく、外部ブログカード作成時に当サーバーからデータを取得できない状態だったか何かが原因かと思います。
      修正するには、ブログカードキャッシュの更新を行ってみてください。
      Simplicityの外部ブログカードのキャッシュの更新方法

    • #44144
      sainoa
      ゲスト

      「キャッシュ更新モード」を有効にしてページを読み直してみました。

      こちらのページ、

      http://wordpress.sainoa.com/archives/97

      三つの外部カードを並べておりますが、読み直しのタイミングによって上の二つも「This page is error.」になります。三つ目だけは何度読みなおしても「This page is error.」のままです。今は、二つ目と三つ目が「This page is error.」になった状態で「キャッシュ更新モード」を無効にしてあります。

    • #44156
      わいひらわいひら
      キーマスター

      それに関しては、こちらのテスト環境では正常に動作しているので、原因はちょっとわからないです。
      修正するにしても、再現方法がわからないと何ともできないと思います。
      一応一つ確認ですが、1つの投稿に1つだけテスト的にSimplicityトップページへのURLを貼っても「This page is error.」が出ますでしょうか?

      Simplicityでは、うまく動作しなかった場合の保険として、他にも機能で選択できるようになっているので、どうしてもうまくいかない場合は、「はてなブログカード」とかを使うしかないかもしれません。

    • #44164
      sainoa
      ゲスト

      https://wp-simplicity.com/

      と一行だけ書いたページを投稿しました。

      http://wordpress.sainoa.com/archives/369

      残念ながら、「This page is error.」になってしまいます。「キャッシュ更新モード」をオンにして10回くらい読みなおしてみましたが、変りません。

      よりによって、Simplicityの公式サイトがエラーになってしまうのが、何とも残念ともうしますか…。

    • #44165
      ハチ
      ゲスト

      因みに
      外部ブログカードのサムネイルは
      アイキャッチ画像がある場合
      表示されるのかな?

    • #44187
      わいひらわいひら
      キーマスター

      ダメ元で、以下の短縮URLでも、エラーは出るでしょうか?
      https://goo.gl/s2scMU

      うまくいかないようであれば、せめて何のエラーが出るかは知りたく思います。
      URLを、https://wp-simplicity.com/にして、
      親テーマのlib/open-graph.phpの以下の部分を
      $res = wp_remote_get( $URI, $args );
      以下のように表示してブログカード表示させてみてもらっていいでしょうか。

      $res = wp_remote_get( $URI, $args );
       echo('<pre>');
       var_dump($res);
       echo('</pre>');

      出てくるテキストを、コードを貼り付ける容量で、このトピックに貼り付けていただければと思います。

    • #44216
      sainoa
      ゲスト

      短縮URLでも同じエラーでした。

      変数のダンプ結果は以下のとおりです。

      object(WP_Error)#3189 (2) {
        ["errors"]=>
        array(1) {
          ["http_request_failed"]=>
          array(1) {
            [0]=>
            string(17) "SSL connect error"
          }
        }
        ["error_data"]=>
        array(0) {
        }
      }

      SSL絡みのようですね。

    • #44222
      わいひらわいひら
      キーマスター

      エラーメッセージで検索してみると、以下のような原因らしきものが出ました。
      PHPのcurlで"SSL Connection Error."のエラーがどうしても出る時の対策 | ブログ :: Web notes.log
      [PHP] RedHat/CentOSのcurlで”SSL Connection Errorが発生しちゃった件 | harumaki.net
      お使いのサーバーのSSL Versionは、どのようなものでしょうか?

      また、おそらくSSLサイト内容の取得が問題のようなので、他にSSLサイトを外部ブログカードで表示させるとエラーが出ますでしょうか?
      例えばお使いのサーバーのページとか。
      https://wp.z.com/jp/

    • #44224
      technote
      ゲスト

      テーマのカスタマイズの「カード幅を広げる」が無効の時.hover-cardにwidth:500pxが適用されるため、スマホなどで表示した時に幅がおかしくなるようです。

    • #44230
      sainoa
      ゲスト

      phpinfo()を見てみたところ、案の定(?)NSSでした。

      SSL Version NSS/3.19.1 Basic ECC

      ところが、https://wp.z.com/jp/ は、正常に表示されます。
      テストページの三つ目に入れてみました。

      http://wordpress.sainoa.com/archives/369

      当該箇所の変数のダンプ結果は以下のとおりです。

      array(5) {
        ["headers"]=>
        array(13) {
          ["date"]=>
          string(29) "Tue, 09 Aug 2016 09:15:02 GMT"
          ["server"]=>
          string(6) "Apache"
          ["strict-transport-security"]=>
          array(2) {
            [0]=>
            string(16) "max-age=15768000"
            [1]=>
            string(16) "max-age=15768000"
          }
          ["x-frame-options"]=>
          string(10) "SAMEORIGIN"
          ["x-xss-protection"]=>
          string(13) "1; mode=block"
          ["x-content-type-options"]=>
          string(7) "nosniff"
          ["vary"]=>
          string(26) "User-Agent,Accept-Encoding"
          ["link"]=>
          array(2) {
            [0]=>
            string(56) "; rel="https://api.w.org/""
            [1]=>
            string(36) "; rel=shortlink"
          }
          ["content-encoding"]=>
          string(4) "gzip"
          ["content-length"]=>
          string(4) "9845"
          ["content-type"]=>
          string(24) "text/html; charset=UTF-8"
          ["set-cookie"]=>
          array(2) {
            [0]=>
            string(76) "multi-device-switcher=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; path=/"
            [1]=>
            string(66) "zcom_wp_language=ja; expires=Wed, 10-Aug-2016 09:15:02 GMT; path=/"
          }
          ["connection"]=>
          string(5) "close"
        }
        ["body"]=>
        string(36901) "
    • #44248
      わいひらわいひら
      キーマスター

      #44224
      不具合を確認したので、手元のファイルを修正しておきました。
      次のバージョンで改善されるかと思います。
      ご連絡ありがとうございます。

    • #44250
      わいひらわいひら
      キーマスター

      #44230
      一応、親テーマのlib/open-graph.phpの以下の部分を

      $args = array(
        'sslverify' => is_ssl_verification_enable(),
        'redirection' => 10,
      );

      以下のように書き換えてうまくいくか試してみてもらっていいですか。

      $args = array(
        'sslverify' => false,
        'redirection' => 10,
      );

      ただ、これでうまくいかないようだと、ちょっとお手上げかもしれません。
      SSLについてそこまで詳しくはないので。

    • #44257
      sainoa
      ゲスト

      sslverifyをfalseにしてみましたが、状況は変りませんでした。

      試しに、httpsのサイトをいくつか並べてみました。

      https://wp-simplicity.com/

      https://goo.gl/s2scMU

      https://wp.z.com/jp/

      https://www.xserver.ne.jp/

      https://www.amazon.co.jp/

      https://www.nhk.or.jp/

      https://www.google.co.jp/

      結果、Googleはエラーでしたが、エラー内容はSSLではなく、403 Forbiddenでした。ダンプ結果を載せようとしたのですが、投稿エラーになってしまったので割愛します。

      SSLだから上手く行かない、というわけではないようです。

      なお、Simplicityのバージョンは、2.2.4ではなく、#44137 で提供いただいたものを使っています。

    • #44259
      わいひらわいひら
      キーマスター

      HTTPSということが原因でないのであれば、もしかしたらCloudFlareが原因とかなのかもしれません。
      当サイトは、最近CloudFlareを導入したので。

      CloudFlareサイトを他にも探してみたので、試しに、以下のURLでブログカードを作っていただいてよいでしょうか。

      CloudFlareのHTTPサイト
      http://did2memo.net/2016/05/14/cloudflare-email-protected/
      http://web-gimmick.com/wordpress/1301/

      CloudFlareのHTTPSサイト
      https://srytk.com/301.html
      https://tbd.kaitoy.xyz/2016/07/01/https-support-by-cloudflare/

    • #44260
      sainoa
      ゲスト

      テストページの下に追加してみました。

      http://wordpress.sainoa.com/archives/369

      結果は、「CloudFlareのHTTPSサイト」はエラーになりました。

    • #44262
      technote
      ゲスト

      ECC系の暗号化スイートを使用できるようにすれば解決するような気がします。
      http://blog.tojiru.net/article/437364535.html

      curl_setoptで暗号化スイートを設定できます。
      ただECC系の暗号化スイートを追加するだけは無理なので、使用しそうな暗号化スイートを全て列挙する必要があります。
      暗号化スイートはこちらを参考にしました。
      https://github.com/hirak/prestissimo/pull/69/files

      1. lib/open-graph.phpの以下の部分を書き換える

      $args = array(
        'sslverify' => is_ssl_verification_enable(),
        'redirection' => 10,
      );

      =>

      $args = array(
        'sslverify' => is_ssl_verification_enable(),
        'redirection' => 10,
        'simplicity' => true,
      );

      2. 子テーマなどのfunctions.phpに以下のコードを記述(PHP5.3以上)

      add_action('http_api_curl', function($handle, $r) {
      	if (isset($r['simplicity'])) {
      		$cipher_list = array(
      			"rsa_3des_sha",
      			"rsa_des_sha",
      			"rsa_null_md5",
      			"rsa_null_sha",
      			"rsa_rc2_40_md5",
      			"rsa_rc4_128_md5",
      			"rsa_rc4_128_sha",
      			"rsa_rc4_40_md5",
      			"fips_des_sha",
      			"fips_3des_sha",
      			"rsa_des_56_sha",
      			"rsa_rc4_56_sha",
      			"rsa_aes_128_sha",
      			"rsa_aes_256_sha",
      			"rsa_aes_128_gcm_sha_256",
      			"dhe_rsa_aes_128_gcm_sha_256",
      			"ecdh_ecdsa_null_sha",
      			"ecdh_ecdsa_rc4_128_sha",
      			"ecdh_ecdsa_3des_sha",
      			"ecdh_ecdsa_aes_128_sha",
      			"ecdh_ecdsa_aes_256_sha",
      			"ecdhe_ecdsa_null_sha",
      			"ecdhe_ecdsa_rc4_128_sha",
      			"ecdhe_ecdsa_3des_sha",
      			"ecdhe_ecdsa_aes_128_sha",
      			"ecdhe_ecdsa_aes_256_sha",
      			"ecdh_rsa_null_sha",
      			"ecdh_rsa_128_sha",
      			"ecdh_rsa_3des_sha",
      			"ecdh_rsa_aes_128_sha",
      			"ecdh_rsa_aes_256_sha",
      			"echde_rsa_null",
      			"ecdhe_rsa_rc4_128_sha",
      			"ecdhe_rsa_3des_sha",
      			"ecdhe_rsa_aes_128_sha",
      			"ecdhe_rsa_aes_256_sha",
      			"ecdhe_ecdsa_aes_128_gcm_sha_256",
      			"ecdhe_rsa_aes_128_gcm_sha_256",
      		);
      		curl_setopt($handle, CURLOPT_SSL_CIPHER_LIST, implode(',', $cipher_list));
      	}
      }, 10, 2);

      私のテスト環境では上記修正でCloudFlareのHTTPSサイトも正しく表示されるようになりました。
      ただgoogle.co.jpに関しては上記プログラムを追加してもbot扱いされて403になりエラーページ表示は治りませんでしたが、それはどうしようもなさそうです。

    • #44275
      わいひらわいひら
      キーマスター

      >sainoaさん
      よかったら、technoteさんの方法を試していただければ幸いです。
      これで取得できるようであれば、テーマに組み込みたいと思います。

      それにしても、こんな方法があるんですね。
      僕だったら、逆立ちしても出てこない方法です。
      ありがとうございます!

    • #44278
      sainoa
      ゲスト

      今、ちょうど試していたところです。

      結果から言うと、無事、上手く行きました。

      http://wordpress.sainoa.com/archives/369

      今現在は、テストのため、「キャッシュ更新モード」を有効にしています。ですので、表示が遅いかもしれません。

      それと、追加コードは、子テーマではなく、親テーマのfunction.phpに設置しました(ファイルの一番下に置きました)。

    • #44279
      わいひらわいひら
      キーマスター

      あれ、うまく表示されています?
      僕がみてみた感じでは、まだエラーになっています。
      このページ。
      http://wordpress.sainoa.com/archives/369
      もしかして、ページキャッシュプラグインとかを利用していますか?

      「キャッシュ更新モード」は有効になっていたとしても、ログインユーザーにしか更新権限はないので、こちらからは更新できない仕様になっています。

    • #44281
      sainoa
      ゲスト

      失礼しました。キャッシュプラグインは使っていませんが、サーバ自体がキャッシュ機能を持っていますので、そのキャッシュをクリアしました。

      第三者からのアクセスを想定して、スマートフォンからアクセスしてみました(電話回線)。上手く表示されているので、大丈夫だと思います。

      「キャッシュ更新モード」は無効化しておきました。

    • #44317
      わいひらわいひら
      キーマスター

      今度は正常に動作しているのを確認しました。
      早速、最新版にてtechnoteさんの方法を組み込んで見たのでまだ試してみていただければ幸いです。
      https://wp-simplicity.com/simplicity2-2-5/
      sainoaさんには、大変なバグフィックスにお付き合いいただいてありがとうございます!

      また、僕には解決できそうもない問題の対処方法を教えていただいたtechnoteさんにも感謝いたします。

      • この返信は3年、 6ヶ月前にわいひらわいひらが編集しました。理由: 敬称が抜けていた
    • #44326
      sainoa
      ゲスト

      2.2.5をインストールしました。httpsサイトの外部ブログカードもエラーなく表示されます。
      もちろん、サーバ側のキャッシュはクリアし、キャッシュ更新モードも一旦有効化して、外部ブログカードの情報を更新しました。
      わいひらさん、technoteさん、ありがとうございました。

29件の返信スレッドを表示中
  • トピック「「エントリーカード全体をリンク化」で外部カードのタイトルが外に追い出される」には新しい返信をつけることはできません。
スポンサーリンク
アドセンス(大)
アドセンス(大)