Simplicityの特徴 › フォーラム › Simplicity2に関する話題何でも › simplicty2をアップグレード後にアクセス不能
-
投稿者投稿
-
-
2016年9月18日 4:56 PM #45316
Y. Kondoh
ゲスト早速ですが、
いつものようにsimplicty2を最新版にアップグレードしようとしました。
作業直前は全く問題なし。
Simplicity2.3.αをダウンロードしてFTPソフトでいつものようにアップロードしました。
いつもやっている慣れた作業です。他には何もしていません。当然ですが、今までの同様の作業でも問題ありませんでした。
しかし、今回はアップロード完了後にアクセスすると
『「ここに私のブログURLが表記」ページは機能していません。』と表記されたページが表示されるだけです。
次の行に、
「ここに私のブログURLが表記」 では現在このリクエストを処理できません。
と書かれています。
iPadでアクセスすると真っ白なページが表示されるだけです。当然管理画面にもアクセスしようがありません。
いったい何が起こったのでしょうか?私はどのようなミスをしたのでしょうか。
こんなことは初めてのことで、何をどうしたらよいのか皆目分かりません。アドバイスがあればよろしくお願いします。
-
2016年9月18日 6:25 PM #45317
わいひらキーマスターWordpressをデバッグモードにして、もしエラーメッセージが出てきたらそのまま貼り付けてください(掲載したくない部分が伏せ字にして)。
WordPress初心者におすすめ!デバッグモードの使い方 | Mignon Styleエラーメッセージが出ないようなら、ここから過去バージョンをダウンロードして上書きアップロードすると、もしかしたら改善されるかもしれません。
https://wp-simplicity.com/downloads/downloads2/ -
2016年9月19日 11:29 AM #45333
Y. Kondoh
ゲストご教示ありがとうございました。
エラーが表示されました。
Parse error: syntax error, unexpected T_FUNCTION in /home/xxxxxxxx/www/blog/wp-content/themes/simplicity2/functions.php on line 1046
私自身は、テーマのカスタマイズくらいしかできることはなくphpファイルを触るのも今回が初めてです。そもそもそういう知識がありません。
エラーの内容を見ると、simplicity2 の functions.php ファイルの 1046行目に何からのエラーがあるということのようですが、これ以上の意味は分かりません。
自分では何も手を加えていないのに上記のファイルにエラーが生じる理由も分かりません。それとも気づかないうちに何かしてしまったのでしょうか。
よろしくお願いいたします。
-
2016年9月19日 1:18 PM #45334
わいひらキーマスターPHPの文法エラーのようです。
Simplicity2.3.0aの該当行周辺は以下のようになっています。//Wordpress管理画面でJavaScriptファイルも編集できるようにする wp4.4以降 add_filter('wp_theme_editor_filetypes', function ($default_types) { $default_types[] = 'js'; return $default_types; });特に文法も問題ないようで、当サイトや開発環境では、問題なく動作しています。
文法エラーの場合、エラーがあれば当サイトや開発環境でも動作しなくなると思うのですが、動作しているということは、意図せず何かしらの編集が加わってしまったのかもしません。なので、微細にサーバー上にあるfunctions.phpの1046行周辺のコードをこのトピックに貼り付けてみてください。文法エラーがあれば、多分すぐに分かるかと思います。
コードの貼り付け方は以下。
https://wp-simplicity.com/suport/topic/first-time/ -
2016年9月19日 2:56 PM #45336
Y. Kondoh
ゲストご返信ありがとうございます。
これでよろしいでしょうか。//Wordpress管理画面でJavaScriptファイルも編集できるようにする wp4.4以降 add_filter('wp_theme_editor_filetypes', function ($default_types) { $default_types[] = 'js'; return $default_types; }); -
2016年9月19日 4:29 PM #45344
わいひらキーマスター見たところ、ソースコードには問題がないような気がします。
上のソースコードは、サーバー上にあるソースコードをコピペしたものですよね?こちら側から、生のソースコードを確認することはできないので、完全に原因を確認するのは難しいです。
なので、対処法として、書き込まれたソースコード部分をすべて削除してみてください。それでもダメなら、以下から最新版2.3.0bをダウンロードしてサーバーに上書きアップロードしてみてください。
https://wp-simplicity.com/downloads/downloads2/それでもダメなようなら、過去バージョン一覧から、以前使っていた古いバージョンを上書きアップロードしてみてください。
-
2016年9月19日 5:21 PM #45348
Y. Kondoh
ゲスト> サーバー上にあるソースコードをコピペしたものですよね?
そうです。私自身見比べてみましたが違いは分かりませんでした。1.書き込まれたソースコード部分をすべて削除してみてください。
ダメでした。2.最新版2.3.0bをダウンロードしてサーバーに上書きアップロード
ダメでした。3.それでもダメなようなら、過去バージョン一覧から
2.2.9 をアップロードしてみました。上手くいきました。
正常に戻ったようです。簡単に動作確認もしてみましたが、管理画面にも入れますし問題ないようです。ご助言ありがとうございました。
正常には戻りましたが、この後は simplicty2 のアップグレードをどうしたものでしょうか?
simplicity から simplicity2 に移行しましたが大変気に入っていますので、テーマを変えたくはありません。何とか使い続けたいと思っています。
予定では、最新版にアップグレードして、
「Simplicityでより精度の高い関連記事を表示するカスタマイズ方法」にしたがって、設定するつもりでした。アップグレード作業をすると、同じことが起こりそうな気がして不安なのですが、しかし今後アップグレードしないというのも問題かなと思いますし、アドバイスをいただけましたら幸いです。
ちなみに、同じサーバー(さくらインターネット)においてある他のwordpressブログ(他のテーマを使用)も一般のサイトも問題なく機能しています。
-
2016年9月19日 6:16 PM #45350
わいひらキーマスターちょっと、一度試しにfunctions.phpの1046行以降を全て削除して動作させてみてもらって良いですか?
-
2016年9月19日 8:54 PM #45354
Y. Kondoh
ゲストバージョン 2.2.9 のfunctions.phpには1010行までしかありませんし、上記の文字列もありあせん。1046行付近のコードは、確かごく最近のアップグレード内容だったように思いますが…。
-
2016年9月19日 9:47 PM #45355
わいひらキーマスター言葉が足りませんでした。2.3.0bで試していただきたく思います。
こちらでは不具合が再現できないので、原因を探るには、問題点を推測するしかありません。
試していただくことで、僕の予想通りの結果なら修正できるかと思います。でないと、今後も2.2.9を利用していただくことになるかもしれません。
-
2016年9月19日 10:07 PM #45361
Y. Kondoh
ゲストお手数おかけしています。
> 僕の予想通りの結果なら修正できるかと思います。
希望が持てます。有り難いです。今まで通り、アップグレードしながら使わせていただきたいですから、ご指示にしたがって試してみます。
ただ、作業が真夜中過ぎてか明日の午前中になります。
お忙しい中お手間を取らせて本当に申し訳なく思います。
よろしくお願いいたします。 -
2016年9月19日 10:16 PM #45364
hidekichi
ゲストちなみにwordpressのバージョンはいくつでしょう?
-
2016年9月19日 10:28 PM #45366
Y. Kondoh
ゲストhidekichiさん、こんばんは。お世話になります。
バージョンは【4.6.1–ja】です。
-
2016年9月19日 10:29 PM #45367
わいひらキーマスター上に書いた、コードの削除を試した後は、以下のファイルの上書きアップロードも試していただけると助かります。
https://wp-simplicity.com/wp-content/uploads/2016/09/simplicity2.zipもしかしたら、フックに直接関数を指定した書き方が、(サーバーの設定もしくはWordpressのバージョンが影響して)不具合が出ているかもしれないので、それを修正したものになります。
上記ファイルの上書きアップロードでうまくいく場合は、そのfunctions.php内の書き方で行こうかと思います。 -
2016年9月19日 10:36 PM #45369
Y. Kondoh
ゲスト承知いたしました。やってみます。
-
2016年9月20日 9:35 AM #45382
Y. Kondoh
ゲストおはようございます。お世話をおかけしています。m(._.)m
1.2.3.0b functions.phpの1046行以降を全て削除して動作
上手くいきました。2.simplicity2.zip の上書きアップロード
上手くいきました。1ユーザーのために大変なお手間を取らせてしまいましたが、本当に助かりました。ただただ感謝、感謝です。
私の方は、simplicity2.zip をこのまま使えばよろしいでしょうか。
-
2016年9月20日 9:49 AM #45383
Y. Kondoh
ゲストご報告です。
「Simplicityでより精度の高い関連記事を表示するカスタマイズ方法」に関して
カスタマイズ用のコードをSimplicity2の子テーマのfunctions.phpにコピー&ペーストして上書きしたところ、機能しなくなりました。同じ症状です。
functions.php を元に戻したところ回復しました。
php言語のことは分かりませんが、「フックに直接関数を指定した書き方が、(サーバーの設定もしくはWordpressのバージョンが影響して)不具合が出ている」ということなのでしょうか。
-
2016年9月20日 10:10 AM #45385
Y. Kondoh
ゲストご報告です。
https://technote.space/cfiltering
念のために、上記ページで CFiltering の情報を確認したところ★必須条件
PHP5.4以上
WordPress3.9.13以上★PHPの方はPHP5.4以上でしか使用できない機能を使用しているため、絶対に必要な条件です。
とありましたので、サーバーの管理画面で確認したところ、
PHPのバージョンは、5.2 になっていました。現在推奨になっている PHP5.6 にして、再設定したところ機能するようになりました。
ということは、最初のトラブルも原因は php のバージョンにあったということになるのでしょうね。
そうだとしたら大変なお手数をおかけしてしまい申し訳ないことです。PHPのバージョンが 5.2 になっていたのは、データベースを最初に設定したときのデフォルトだったのだろうと思います。意味が分からないところは触らないことにしていますので、今回初めて php のバージョンを選択できることを知ったほどです。
以上、ご報告とお詫びです。
-
2016年9月20日 10:21 AM #45386
hidekichi
ゲストquery monitorと言うプラグインがあります。
正常に動作している時にこのプラグインを有効化して、普段遣いでどこかにエラーが出ていないかを確かめられます。もしエラーが出ていたら、アドミンバーの該当部分が赤くなっていると思うので、そこをクリックしたらPHPの警告なり何かしらが表示され、何が問題であるかをおおまかにつかめると思います。warningやnoticeがあっても正常に動作しているようであれば、ひとまず無視でもよいかと思いますが、どこの何が問題ありそうだと言うのを把握して、それらが何をしているスクリプトかを考えると、PHPの設定なりで何をどうするべきかがわかるようになるかもしれません。
一通り動作確認したら、このプラグインは必要はないので停止なり削除なりしてください。
ちなみにうちのサイトで、最新のSimplicity、wordpressで特に同じようなエラーは出てませんでした。PHPの設定もそうですが、wordpress自体が何かしらエラーを含んでる可能性もあるので、再度インストールしてみてはどうでしょうか?
あとサーバーに置いてあるwordpressで、それぞれのサイトごとにwordpressが入っているんですかね?
それとも1つのwordpressをマルチに使っておられるんでしょうか?今回とは関係ないかもしれませんが、WP Multibyte Patchと言う神プラグインが入っていないことが関係してエラーが出ていたと言うケースもありましたので一応念の為書いておきます。
-
2016年9月20日 10:37 AM #45389
hidekichi
ゲストあぁPHPは5.6以上でないと問題がある可能性がありますね。
5.5でも今年の7月あたりにセキュリティサポートが終わっているので、現状では5.6以上にしておくのがベターです。以上とは、5.6.x か 7.0以上と言う感じです。7.0にしたらしたでまた何かしらあるかもしれませんが、うちのサイトも7.0にしてますけれども、特にこれといった問題は起きてないので、しておくのが良いかもしれません。
ポイントは古いプラグインなどを使っていて、そのPHPのバージョンでしか動作しないのであれば古いバージョンを利用するしか無いですが、新しいバージョンでも動作するならPHP自体を古いままにしておく必要はないと言う感じかと思います。
また、7.0の恩恵を受けようとすれば、7.0用に書き直す必要がある部分もあり、7.0それだけでは大きく機能が向上するわけではないのです。一部機能は、一般利用なら5系の方が高速な場合もあります。企業サイトのように扱う配列の数がべらぼうに多いとかでは7のが速いですけれども。
毎回そうですが、PHPのバージョンアップで下位互換性のない変更がいくつか含まれている可能性があるので、今回もおそらくはそういうことだったんでしょうね。
-
2016年9月20日 10:45 AM #45390
Y. Kondoh
ゲストhidekichiさん、お世話になります。
1.query monitorと言うプラグイン
知りませんでした。「正常に動作している時に」ということですので、本当に正常に動作しているかどうかしばらく様子を見てから試してみようと思います。2.wordpress自体が何かしらエラーを含んでる可能性もあるので、再度インストールしてみてはどうでしょうか?
サーバーの管理画面から行うインストールのことですよね。そういう再インストールはやったことがないので少々不安がありますが考えてみます。初期化されてしまうと言うようなことは無いのでしょうか。管理画面を確かめたところ、「テーブルの接頭語を入力してください」とありますが、これを同じものにしないと大変なことになりそうなのですが。インストールした際の接頭語を忘れています。どこを見ればたしかめられるのでしょうか?
3.サーバーに置いてあるwordpressで、それぞれのサイトごとにwordpressが入っているんですかね?
そうです。マルチで使う知識がありません。(^^;)4.WP Multibyte Patchと言う神プラグイン
聞いたことがあるなと思ったら入っていました。情報ありがとうございました。勉強になります。
-
2016年9月20日 10:49 AM #45391
Y. Kondoh
ゲストhidekichiさん、
さくらインターネットの場合、5.6.24 が一番新しいバージョンのようです。これが推奨になっています。
-
2016年9月20日 11:02 AM #45392
technote
ゲストadd_filter('wp_theme_editor_filetypes', function ($default_types) { $default_types[] = 'js'; return $default_types; });無名関数はPHP5.3から使用可能な機能です。
PHP5.4からは無名関数内で$thisが使用できます。
PHP5.3未満に対応させるには、以下のように関数を定義してあげるか、create_functionを使用する必要があります。function add_editor_filetypes($default_types) { $default_types[] = 'js'; return $default_types; } add_filter('wp_theme_editor_filetypes', 'add_editor_filetypes'); -
2016年9月20日 12:03 PM #45394
hidekichi
ゲストphpのバージョンアップで問題ないならwordpressの再インストールは必要ないと思います。
> インストールした際の接頭語を忘れています。
> どこを見ればたしかめられるのでしょうか?何の作業でのテーブル接頭辞の設定かわかりませんが、wp-config.phpにデータベース等の設定があると思います。
/*WordPress Database Table prefix. */ $table_prefix = 'wp_';こういう部分。「wp_」が接頭辞です。wp-config.phpは変更する必要はありません。確認するだけでokです。念の為。
今回の(PHPバージョンでの)エラーが出ていた箇所は、wordpress上でjsファイルを編集するための機能です。ローカルで自身のテキストエディター等で編集してftpでアップロードするなら必要のない機能ですので、わいひらさんもエラー箇所以降を削除と言う話になったんだろうと思います。
むしろ、ローカルで編集したものをftpでアップロードするほうが良いです。全角スペースや;抜け等のエラーで動作しなくなる場合もありますので、それらを確認できるテキストエディタとそのプラグイン等で確認したファイルをアップロードするのが一番良いかと思います。
スクリプト中の例えば「submit」部分を「送信」に変えたいなどと言う簡単な変更ならwordpress上でするのが良いですが、そうするとバックアップはどうする?サーバーとローカルでファイルが異なっていたらどうする?(サーバーの方が編集が進んでいてローカルが古いと言うのはあまりよくない)と言う問題にもなりますので、必ずローカルでは各ファイルのバックアップを取ってから作業をしてアップロードと言う手順ならwordpress上での編集も有効です。
サーバー上では正常に動作する各ファイルのバージョンが動いていて、最新のファイルは手元にあると言うのが本来の形です。この状態で編集用とバックアップ用のフォルダを分けておき、バックアップ用とサーバーを同期させておきます。
ftpでサーバーの最新状態 = ローカルのバックアップとなっていれば、編集用の最新ファイルをアップロードしても手元に最新であったサーバーのファイルがバックアップされているわけですので、最新ファイルに何かしらあっても一つ前の状態に戻ることができます。wordpress上で更新すると、手元のバックアップ用ファイルのバージョンが、更新した分だけ何代も前のものになっている可能性があります。ここらを気をつけて、ある程度の所でバックアップを取っておけば何かあった際にすぐに元に戻せます。また戻せるようにしておくのが良いです。
何かしらあれば全部再インストールして1からと言うぐらいの気概があればどう使おうと良いんですけどね。
-
2016年9月20日 12:35 PM #45395
Y. Kondoh
ゲストtechnoteさん、
phpのことは全く分かりませんが、たまにはサーバーの管理画面でバージョンのチェックはしておくべきだということだけはよく分かりました。
ありがとうございました。
hidekichiさん、
> 何かしらあれば全部再インストールして1からと言うぐらいの気概があればどう使おうと良いんですけどね。
そのような気概はもとよりございませんので、
『サーバー上では正常に動作する各ファイルのバージョンが動いていて、最新のファイルは手元にあると言うのが本来の形です。』を心掛けたいと思います。1年8ヶ月前に今回のブログ構築後すぐに simplicity を導入して、その後 simplicity2 へと移行しても、今までトラブルはありませんでしたので、最近はバックアップに対する意識が薄れていました。
初めてWordPressを使い始めた数年前は原因に心当たりがハッキリとある大きなトラブルでそれこそ一から再構築という目に遭いまして、それ以降はバックアップにはかなり神経質になっていたのですが、調子のよい状態が続いている内におざなりになっていました。
今回のことがあり、「最新ファイルに何かしらあっても一つ前の状態に戻せる」状況だけは確保しておこうと思います。
いろいろとご助言ありがとうございました。
このテーマにこういうフォーラムがあって本当に助かりました。感謝。
-
2016年9月20日 1:14 PM #45401
-
2016年9月20日 1:50 PM #45404
hidekichi
ゲストオーバーライド、remove_actionとか、remove_filterのことも忘れないであげてください(笑)
無名関数だと、さっくり削除・子テーマでの上書き等がやりにくいかもしれません。
-
2016年9月20日 1:59 PM #45405
Y. Kondoh
ゲストわいひらさん、
この度は本当にお世話になりました。ありがとうございました。
simplicity のさらなる発展を楽しみにしております。
-
2016年9月20日 2:52 PM #45415
わいひらキーマスターオーバーライド、remove_actionとか、remove_filterのことも忘れないであげてください(笑)
あらら、完全に忘れていましたよ(笑)
これまで、何度もカスタマイズやプラグインのインストールによる「関数の再定義エラー」の書き込みがあったので、ついつい「これいいじゃん!」と思ってしまいました。
やっぱ、なるべく重複しないような関数名をつけたほうがよさそうですね。
-
-
投稿者投稿
- トピック「simplicty2をアップグレード後にアクセス不能」には新しい返信をつけることはできません。