突如としてエラーの嵐に

Simplicityの特徴 › フォーラム › 不具合報告 › 突如としてエラーの嵐に

  • このトピックには10件の返信、2人の参加者があり、最後にMoriにより10年、 8ヶ月前に更新されました。
10件の返信スレッドを表示中
  • 投稿者
    投稿
    • #35615
      Mori
      ゲスト

      こんばんは、いつもお世話になっています。
      本日、急に以下のようなエラーメッセージがブログに表示されるようになり、焦っています。

      Notice: Undefined index: header_height in /home/moriaqua/mori-room.com/public_html/wp-content/themes/simplicity/lib/customizer.php on line 3008

      Notice: Undefined index: list_style in /home/moriaqua/mori-room.com/public_html/wp-content/themes/simplicity/lib/customizer.php on line 3294

      Notice: Undefined index: list_style in /home/moriaqua/mori-room.com/public_html/wp-content/themes/simplicity/lib/customizer.php on line 3294

      Notice: Undefined index: japanese_slug_enable in /home/moriaqua/mori-room.com/public_html/wp-content/themes/simplicity/lib/customizer.php on line 4278

      Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method collapsCat::init_textdomain() should not be called statically in /home/moriaqua/mori-room.com/public_html/wp-includes/plugin.php on line 525

      Notice: Undefined index: webmaster_tool_id in /home/moriaqua/mori-room.com/public_html/wp-content/themes/simplicity/lib/customizer.php on line 4214

      また、管理画面の上部には常に、

      cts parameter 1 to be a valid callback, non-static method collapsCat::init_textdomain() should not be called statically in /home/moriaqua/mori-room.com/public_html/wp-includes/plugin.php on line 525

      というような文字が表示されます。
      朝はきちんと表示をされていて、その後は何もいじっていないので、原因不明です。

      他の運営しているブログはいたって普通。
      エックスサーバーでmod_pagespeedをオフにしても意味はなく。
      PHPのバージョンを5.5か5.6から、5.3.3(非推奨ですが)にし、テーマをTwenty Sixteenに変更することで、ようやくエラー表示は消えました。
      Simplicityに戻すと、またエラーの嵐となります。。。。

      一体、何が起きているのでしょうか。

    • #35617
      いのぽん
      ゲスト

      プラグインの「brBrbr」をとりあえず停止してみてはいかがでしょうか。

    • #35618
      Mori
      ゲスト

      その後、Simplicity 2β版をインストールし、PHPバージョンを5.6に変更すると、プラグインエラーがおきました。

      ・post-views
      ・Custom Query String Reloaded

      これらを停止すると、ブログ(http://mori-room.com/)に以下のエラーが表示されるだけになりました。

      Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method collapsCat::get_head() should not be called statically in /home/moriaqua/mori-room.com/public_html/wp-includes/plugin.php on line 525

      PHPのバージョンを5.3.3に変更にするエラーは消えました。現状としてはエラーが出ていないのでそのままにしています。

    • #35619
      Mori
      ゲスト

      >いのぽんさん

      いろいろとやった結果、今のところ、BrbrBrの有効化してもエラーは出なくなりました
      あいわらず原因不明です

    • #35620
      アバター画像わいひら
      キーマスター

      それは、エラーメッセージというか通知メッセージです。(Notice)
      おそらくWordpressがデバッグモードになっています。
      Wordpressルート直下の wp-config.php にある

      define('WP_DEBUG', true);

      を

      define('WP_DEBUG', false);

      に変更してみてください。

      「Notice WordPress」で検索すると詳しい情報が出てくるかと思います。

      もしくは、Simplicity2にアップデートするとおそらくデバックモードでも表示されないと思います。
      ただ以下のような、プラグインに起因するものはそのまま表示されます。
      public_html/wp-includes/plugin.php on line 525

    • #35621
      Mori
      ゲスト

      >わいひらさん

      ありがとうございます。

      確認したところ、wp-config.php が define(‘WP_DEBUG’, false); にもともとなっていました。

      新規記事を書こうとすると、

      Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 86 bytes) in /home/moriaqua/mori-room.com/public_html/wp-includes/meta.php on line 835

      のみが表示されて、新規作成ができません。

      public_html/wp-includes/plugin.php on line 525 のエラーは一体何が原因でしょうか?

      まったく意味がわからずに困っています。。。

    • #35622
      アバター画像わいひら
      キーマスター

      そのエラーメッセージは、エラーに書かれているディレクトリーを見てもSimplicityディレクトリではないので僕からは、確かなことわからないです。
      実際に、そこに書かれている行番号のところに何が書かれているかを見て見て原因を探るとか、エラーメッセージなどで検索して解決方法を探るしかないかもしれません。

      とりあえず、プラグインを一つずつ無効にして、エラーが表示されなくなったらそのプラグインが原因とかを探るしかないかもしれません。

    • #35623
      Mori
      ゲスト

      >わいひらさん

      いろいろとありがとうございます。
      エックスサーバーに問い合わせのメールを送りました。

      その後、、、不思議なことに、すべての不具合がなぜか解決しています。確認した限りですが。
      PHPも5.6にしても問題ありませんし、テーマを1.9の方にしても問題ありませんし。。。

      サーバーの仕様変更か何かのミスだったのかもしれません。
      以前にも、エックスサーバーのメンテで、ブログの表示がおかしくなるということがあり、大変でした。
      今回もそうかもしれません。

      エラーコードにSimplicityとあり、とても焦ってこちらに書き込ませていただきました。
      結果的に、ただの焦り過ぎだったのかもしれません。
      ご迷惑おかけしました。ありがとうございました。おそらく解決です

    • #35625
      Hidekichi
      ゲスト

      たいていメモリサイズのエラーが出るのは、キャッシュが存在することで整合性が取れない場合などです。
      同じ処理でキャッシュの及ばない部分で何かしらが実行されると、キャッシュが存在するものとのバッティングで、あれ?ん?なんかおかしくない?いやファイル名はあってるし…けどあれ…?みたいなことが起こり、何度もリトライすることになったりします。

      そうすると、本来1度で済むことが何度も繰り返されるのでメモリサイズが圧迫されるわけです。

      例えば怪しいな・オカシイなと稲川淳二バリに、ここではないかというフォルダをftpなとで見ると、びっくりするぐらいファイルが作られていたりすることがあります。今回は使われていないと思うんですけどヘッドクリーナーとかもそうです。

      268435456 bytesは、おおよそ256MBだと思うので、php.iniかWP_MEMORY_LIMITが256MBで設定されていたんだろうと思います。これを516MBに変えてみたりすることで、ひとまず現在の滞っている処理を終わらせて復帰できるかも知れませんが、どんどんファイルが作られていくタイプや、処理が滞っていて進めなくてリトライしている場合はこれでは解決できないかも知れません。

      > plugin.php on line 525

      これは例えばadd_actionなどのトリガーを数えてる部分ですね。
      処理できないアクションがめっちゃたまったんだろうと予測できますが、それが何かは特定ができかねます。

      最初に書いたように何かしらのキャッシュが問題だとすればmod_pageSpeedあたりのキャッシュで問題が出たのではなかろうかと思ったりします。で、サーバーに連絡入れたことで、管理人が確認したらエライことになっていたので管理者がテンポラリファイル等をさっくり削除して何もなかったことになっているのではないかと思ったり(笑)

    • #35630
      アバター画像わいひら
      キーマスター

      デバッグモードをいじってないのに、Noticeが表示されること自体ちょっとアレなので、以前もサーバーのメンテでおかしな事があったのなら、サーバーが何かやってたと考えても良いのかもしれません。

    • #35635
      Mori
      ゲスト

      >Hidekichiさん >わいひらさん

      返信ありがとうございます。
      php.iniをたしかに増やしていました。以前、何かの処理をするときに支障が出ていたので。
      今回もエラーが出た時に増やしています。

      原因については何もわかりませんが、何もなかったかのような挙動です。
      結果的にphp.iniを増やしただけで、何かしたわけでもないです。

      エックスサーバーの対応は、「個別のことには対応できません」とのことで、まずはログファイルからエラーメッセージを確認して、不明な点を問い合わせして欲しいとのことでした。

      狐につままれたような出来事でした。
      いろいろとありがとうございました

10件の返信スレッドを表示中
  • トピック「突如としてエラーの嵐に」には新しい返信をつけることはできません。
スポンサーリンク
アドセンス(大)
アドセンス(大)