独自キャッシュのブログカードでエラーが出る件、コメントありがとうございました。
無事、独自キャッシュのブログカードを利用できるようになったのですが、まだ不具合があるためトピックを立てさせていただきました。
ブログカードは表示されるようになったのですが、一部のブログカードで画像がエラーになります。
例えば、以下の記事です。
http://masalog.net/narrative-clip-2-has-shipped.html
3つ外部リンクがあるうち、上の2つのOGP画像は元サイトのものを使っているようで表示されます。
(この動作が正しいのかはよく分からないのですが表示的には問題ありません)
一番下のもののみキャッシュになっているようなのですがエラーになります。
リンク先の画像ファイル名をみると以下のようになっています。
261dd715ebee9a0c4fb62860c2389d83.jpeg?fit=1408%2C842
ftpでキャッシュフォルダをみると以下の2つのファイルが作成されています。
261dd715ebee9a0c4fb62860c2389d83.jpeg?fit=1408%2C842
261dd715ebee9a0c4fb62860c2389d83.jpeg?fit=1408%2C842.jpg
ためしに上のファイルのファイル名を手作業で
261dd715ebee9a0c4fb62860c2389d83.jpeg
に変更すると画像が表示されるようになりました。
他の記事でも同様の症状が発生しています。
例えば、以下の記事の5番目のリンクのみ同様のエラーになっています。
http://masalog.net/weekly-articles-20160202.html
全てのリンクで起きるわけではないようなのですが、対応方法等ありますでしょうか。