SEO設定に入力した内容が消えてしまう

Simplicityの特徴 フォーラム Simplicity2に関する話題何でも SEO設定に入力した内容が消えてしまう

このトピックには30件の返信が含まれ、2人の参加者がいます。2 ヶ月、 3 週間前わいひら わいひら さんが最後の更新を行いました。

  • 投稿者
    投稿
  • #50880 返信

    ぽんちゃん

    以前「SEO設定に入力した内容が消えてしまう」とご相談させて頂いた者です。

    https://wp-simplicity.com/suport/topic/seo%E8%A8%AD%E5%AE%9A%E3%81%AB%E5%85%A5%E5%8A%9B%E3%81%97%E3%81%9F%E5%86%85%E5%AE%B9%E3%81%8C%E6%B6%88%E3%81%88%E3%81%A6%E3%81%97%E3%81%BE%E3%81%86/

    ファイルをアップデートしてからしばらくは大丈夫だったのですが、今気付いたらやはり同じ不具合が発生していました。

    私のサイトはこちらです。
    http://ranking-mania.net/

    SEO設定に入力した内容が消えてしまった記事はこちらです。
    http://ranking-mania.net/akujyo-actress

    そして今回は記事投稿のタイミングではありませんでした。3/6に記事を投稿してからしばらくは大丈夫だったのですが、さっき気付いたらSEO設定に入力した内容が消えていました。

    何のタイミングで消えてしまったのかは分かりませんが、新規で記事を1つ下書き保存したあとにサイトを確認したら消えていました。

    お手数ですが、もう一度確認して頂いてもよろしいでしょうか?

  • #50900 返信
    わいひら
    わいひら
    キーマスター

    ソースコードを見たいので、できれば右クリック無効の何かを切っていただければと思います。

    ただ、ソースコードをを見れたとしても、原因がわかるかはわかりません。
    というのも、自分でも同様に試しているのですが、不具合の再現方法がわからないからです。
    以下のページも、「SEO設定」でメタディスクリプションとキーワードを設定しているのですが、今のところ消えていないようです(いろいろ機能をオン/オフにしてみたけど)。
    https://wp-simplicity.com/simplicity2-5-0/

    ですので、何かのきっかけみたいなものがわからないと、ちょっと何ともできないかもしれません。

  • #50904 返信

    ぽんちゃん

    返信ありがとうございます。

    そうなんですね、了解しました。そこまで重大なことでもないので大丈夫です。
    ただ、いつも同じ場所(上から5つ目)にある記事のSEO設定欄が消えてしまうので、何か原因があるのでは?とご相談させて頂いた次第です。

    一応、右クリック禁止のプラグインを停止しました。
    よろしくお願い致します。

  • #50917 返信
    わいひら
    わいひら
    キーマスター

    確かに他はSEO情報が入っているのに、以下の記事だけないですね。
    http://ranking-mania.net/akujyo-actress

    ただ、いつも同じ場所(上から5つ目)にある記事のSEO設定欄が消えてしまうので、何か原因があるのでは?とご相談させて頂いた次第です。

    こういう情報が重要です。ありがとうございます。
    後で、自分のテスト環境でも、SEO情報を入れて、消えるか確認してみたいと思います。
    もし、次に新しい記事を書いて、5番目に表示されるSEO設定情報が消えたら、教えていただければ幸いです。何か5という数字に関連しそうなところに、原因がある可能性が高いので、探ってみたいと思います。
    何か、他に思い当たることとかがあれば、書き込んでいただければ、それをヒントに出来る限り修正を試みれればと思います。

  • #50928 返信

    ぽんちゃん

    ありがとうございます。
    ちょっと説明が分かりにくいかもしれませんが、思い当たることを載せておきます。

    ・SEO設定に入力した内容が消えてしまうのはいつも同じ場所(上から5つ目の記事)。
    ・記事を投稿したとき、または記事を下書き保存したタイミングで消えることが多い。
    ・ただ、毎回消えてしまうわけではなく、消えないこともある(今のところ2~3回に1回くらいの割合です)。
    ・消えてしまったSEO設定の内容を再度入力し直すと消えることはない。

    これくらいしか情報がありませんが、よろしくお願い致します。
    参考までに、ついさっき新規で記事をアップしましたが消えませんでした。

  • #50948 返信
    わいひら
    わいひら
    キーマスター

    ありがとうございます。
    ちょっと、時間がある時に条件に沿って動作確認してみます。

  • #50963 返信

    やす

    ご質問のやりとりの途中に入る様で申し訳ありません。

    私も同じようにSEOタイトル・メタディスクリプション・キーワードの部分が、入力したはずなのに、しばらく経過してから見ると消えていることが、今までに数回ありました。

    上から5個目とありましたが、私も確かに真ん中あたりだったと思います。

    確かに消えていて、もう1度入力しましたら、消えることはありませんでした。

    私のサイトはhttp://www.wide-tishiki.com/

    になります。

    ぽんちゃん様のように、詳しくは見ていませんが、私もこうした事が、タイトル変更しようと思ったときに、何回かあったので、お知らせさせていただきました。

    割り込むようで申し訳ありません。

    トピックの内容を参考にさせていただきます。

  • #50970 返信
    わいひら
    わいひら
    キーマスター

    先程も、新規投稿を何度もポストして試してみたのですが、同様の不具合が起きません。
    ですので何か、その他に発生条件があるのかもしれません。
    SEO設定は「SEOタイトル・メタディスクリプション・キーワード」すべてが消えてしまうのですよね?

    今後も自分のテスト環境で、SEO設定を設定しつつ投稿し、動作を確かめたいともいます。

    前回の不具合に関しては、テーマカスタマイザーの「画像」項目にある、「アイキャッチを自動設定」機能が原因でした。
    なので、よろしければ、「アイキャッチを自動設定」を無効にして、同様の不具合が起きるか試していただければと思います。
    もし、無効にしていて不具合が起きなければ、「アイキャッチを自動設定」に問題があるということがわかりますし、もし無効にしていても、不具合が起きれば、「それ以外に問題がある」という問題の切り分けを行うことができます。
    なので、(試す期間中はアイキャッチを自分で設定しなくてはいけないので面倒かもしれませんが)よろしかったらで良いのでお願いいたします。

  • #51028 返信
    わいひら
    わいひら
    キーマスター

    まだ確かな原因は分かっていないのですが、怪しい部分を修正したものを「バージョン:2.5.0b」として以下にアップしておきました。
    https://wp-simplicity.com/downloads/downloads2/

    なんで、5番目あたりなのか今のところ全く見当がついていません。
    引き続き、原因を探りつつ注意しながら利用したいと思います。

    #50963
    もし次に同様の問題が起きたら、よろしければそのままの状態(SEO設定が消えたままの状態)にして、ソースコードを見せていただければと思います。
    お忙しいかもしれませんが、よろしければ原因究明のためよろしくお願いいたします。

  • #51094 返信

    ぽんちゃん

    お世話になっております。

    前回の不具合に関しては、テーマカスタマイザーの「画像」項目にある、「アイキャッチを自動設定」機能が原因でした。なので、よろしければ、「アイキャッチを自動設定」を無効にして、同様の不具合が起きるか試していただければと思います。

    「アイキャッチを自動設定」を無効にしていましたが、やはり同じ不具合が発生しました。

    サイトです。
    http://ranking-mania.net/

    今回SEO設定が消えた記事です。
    http://ranking-mania.net/single-man

    SEO設定は「SEOタイトル・メタディスクリプション・キーワード」すべてが消えてしまうのですよね?

    はい、全てが消えてしまいます。

    右クリック禁止のプラグインを再び停止しておきましたので、確認よろしくお願い致します。
    申し訳ありませんが、ソースコードの確認が終わりましたら「もう大丈夫です」とコメントかメールを頂いてもよろしいでしょうか?
    実は最近私のサイトの記事がいくつかそのまま丸ごとコピーされてYouTubeの動画になっているようなので、コピーされないようになるべく右クリック禁止のプラグインを有効化させておきたいと思っています。
    お手数お掛けして大変申し訳ありませんが、よろしくお願い致します。

  • #51097 返信

    Hidekichi

    右クリック禁止はjavascript停止したら効果はありませんし、デベロッパーツールでも無効にできますので意味がありません。

    body { -webkit-user-select: none; /* Chrome all / Safari all */ -moz-user-select: none; /* Firefox all */ -ms-user-select: none; /* IE 10+ */ user-select: none; /* Likely future */ }

    これはbodyタグに範囲選択できないようにするcssです。IE10よりも古いものには効果はありませんがまぁ今時ならこれだけで良いのではなかろうかと。これでもデベロッパーツールで無効にされたらダメですけどね。

    cssは部分的にコピーできるようにもできないようにもできるので便利です。

    動画は著作権情報をウォーターマークで入れておくぐらいしかできないですかね。後は通報か。

  • #51100 返信

    ぽんちゃん

    Hidekichiさん

    ご丁寧にありがとうございます。さっそく教えて頂いた方法を試してみました。どうしたものかと困っていたので大変助かりました。

    一応、動画に引用元として私のサイトのリンクを載せて頂いているようなので、通報などはせずにそのまま様子を見守りたいと思います。引用ではなく一字一句丸ごとコピーされていますが…(笑)。

    わいひらさん

    右クリック禁止のプラグインは削除しますので、連絡を頂かなくても大丈夫です。確認よろしくお願い致します。

  • #51106 返信
    わいひら
    わいひら
    キーマスター

    ご報告ありがとうございます。
    確かに5番目ですね。
    その記事だけ、しばらくそのままにしておいていただけると助かります。
    検証が終わったら、このトピックでご連絡させていただきます。
    同様の設定にして、もう一度試してみようと思います。

  • #51107 返信
    わいひら
    わいひら
    キーマスター

    一つ質問なんですが、今回の不具合が起こったタイミングとしては、以下の記事を投稿したタイミングでしょうか?
    http://ranking-mania.net/hkt-beauty

    あと、現在使用中のプラグインなども教えていただければと思います。

  • #51114 返信

    ぽんちゃん

    お世話になっております。

    その記事だけ、しばらくそのままにしておいていただけると助かります。検証が終わったら、このトピックでご連絡させていただきます。同様の設定にして、もう一度試してみようと思います。

    了解しました。そのままにしておきます。

    一つ質問なんですが、今回の不具合が起こったタイミングとしては、以下の記事を投稿したタイミングでしょうか?
    http://ranking-mania.net/hkt-beauty

    いいえ、違います。その記事は3/13の夕方にアップしたのですが、それからしばらく不具合は発生していませんでした。本日(3/16)の午前中にサイトを見たときは大丈夫だったのですが、16時過ぎにサイトを見たときに消えていました。その間に記事の投稿、下書きなどは一切していません。そのため、何のタイミングで外れてしまったのか今回は全く見当が付きません。

    あと、現在使用中のプラグインなども教えていただければと思います。

    使用中のプラグインは以下の通りです。
    ・AddQuicktag
    ・Akismet Anti-Spam (アンチスパム)
    ・AmazonJS
    ・Black Studio TinyMCE Widget
    ・Broken Link Checker
    ・Category Order and Taxonomy Terms Order
    ・Contact Form 7
    ・EWWW Image Optimizer
    ・Facebook Page Plugin
    ・Font Awesome 4 Menus
    ・Google XML Sitemaps
    ・Limit Login Attempts Reloaded
    ・PS Auto Sitemap
    ・SiteGuard WP Plugin
    ・TinyMCE Advanced
    ・UpdraftPlus – Backup/Restore
    ・WordPress Popular Posts
    ・WP Multibyte Patch
    ・WP-PostViews
    ・ウィジェットのロジック

    あと、実はもう一つ運営しているサイトがありまして、ずっと更新していなかったのですが久し振りに確認したら同じ不具合が発生していました。

    サイトはこちらです。
    http://drama-mania.net/

    ちょっと分かりにくいのですが、確認したら上から5番目と6番目の記事のSEO設定が全て消えていました。

    参考までに、そちらのサイトで使用しているプラグインも載せておきます。
    ・Akismet Anti-Spam (アンチスパム)
    ・AmazonJS
    ・Black Studio TinyMCE Widget
    ・Broken Link Checker
    ・Category Order and Taxonomy Terms Order
    ・Contact Form 7
    ・EWWW Image Optimizer
    ・Font Awesome 4 Menus
    ・Google XML Sitemaps
    ・Meta Slider
    ・PS Auto Sitemap
    ・SiteGuard WP Plugin
    ・TinyMCE Advanced
    ・UpdraftPlus – Backup/Restore
    ・WordPress Popular Posts
    ・WP Multibyte Patch
    ・WP-PostViews

    お手数ですが、よろしくお願い致します。

  • #51141 返信
    わいひら
    わいひら
    キーマスター

    いいえ、違います。その記事は3/13の夕方にアップしたのですが、それからしばらく不具合は発生していませんでした。本日(3/16)の午前中にサイトを見たときは大丈夫だったのですが、16時過ぎにサイトを見たときに消えていました。その間に記事の投稿、下書きなどは一切していません。

    Simplicityには、時間差で何かの処理をする機能はついていないので、何かしらのトリガーとなる行動がないと、「SEO設定が消えてしまう」という設定変更が起こるということはちょっと考えにくいかもしれません(ページ表示でもトリガーとなるけど、それが原因なら見たページ全ページが消えるはず)。
    僕も見た目同様の設定にして、何度もポストしたり、して試しているのですが、今のところ不具合の再現はできていません。
    https://wp-simplicity.com/wp-content/uploads/2017/03/Instant-WordPress-Your-Local-WordPress-Installation-2017-03-17-20-14-04.png
    ※SEO設定が冷える不具合が出ていると「SEOメタディスクリプションX」が「投稿本文X」にならはずなんですが今のところなりません。

    見た感じ怪しいのは以下とかでしょうか。
    ・Broken Link Checker
    ・EWWW Image Optimizer

    Broken Link Checkerで、何かしらリンクを修正したりはしましたか?

    ただ、やはり同じ不具合が出ている人のプラグインもわかれば、原因の特定もしやすいかと思います(テーマが原因の可能性も捨てきれないけど)。
    ですので、#50963のやすさんも、よかったら使用中のプラグインを教えていただければと思います。
    もし、この書き込みを見ることがありましたら、よろしくお願いいたします。

  • #51153 返信

    ぽんちゃん

    見た感じ怪しいのは以下とかでしょうか。
    ・Broken Link Checker
    ・EWWW Image Optimizer

    「EWWW Image Optimizer」は割と最近入れたもので、入れる前から不具合が発生していたので、怪しいのは「Broken Link Checker」かもしれません。

    Broken Link Checkerで、何かしらリンクを修正したりはしましたか?

    ちょっと記憶が曖昧ですが、確かにSEO設定が消えていることに気付く前にリンク切れがあったので修正したと思います。

  • #51176 返信
    わいひら
    わいひら
    キーマスター

    Broken Link Checkerでリンクエラーを修正すると再ポストされることから、それをトリガーとしてSEO設定がクリアされているのかと思いましたが、僕のテスト環境で、リンク修正・リンク解除などしても、不具合は再現されませんでした;
    うーん、なんでなんだろう…。もう1人、他の方の使用プラグインが知りたいところです。

  • #51188 返信

    ましゅー

    こんにちは。

    私もSEO設定がすべてクリアされており、最初「設定し忘れたのかな?」と思っていたのですが、数日前に設定したものが消えているので何かしらの原因があるみたいです。

    ・対象ブログ:
    https://my-turbulence.com/

    ・実際に消えてた記事(現在は修正済み):
    https://my-turbulence.com/tenswall-aroma-diffuser-humidifier

    ・SEO設定が消えててなおかつ未修正の記事:
    https://my-turbulence.com/sizuoka-foods

    またトピック内では「Broken Link Checkerが怪しい」とのことですが、本日実際にBroken Link Checkerでリンク切れ報告があったので「リンク切れではない」を設定しました。

    このリンク切れ報告自体はSEO設定が消えた記事とは無関係の記事なので関係があるのかどうかはよくわかりません。

    ちなみに現在までにこのトピックを参考に以下の2つを試しましたが、改善されませんでした。

    ・アイキャッチを自動設定のチェックを外した(というより元から外している)
    ・バージョン:2.5.0bへアップした

    なお、上記ブログで導入しているプラグインは以下のとおりです。

    ・AddQuicktag
    ・AdSense Manager
    ・Akismet Anti-Spam (アンチスパム)
    ・Attachment Pages Redirect
    ・BackWPup
    ・Broken Link Checker
    ・Category Order and Taxonomy Terms Order
    ・Contact Form 7
    ・Delete Post Revision
    ・EWWW Image Optimizer
    ・Google XML Sitemaps
    ・Imsanityを選択
    ・PHP Code Widget
    ・PS Auto Sitemap
    ・Regenerate Thumbnails
    ・Search Regex
    ・Simple 301 Redirects
    ・Speech bubble (ふきだしプラグイン)
    ・SyntaxHighlighter Evolved
    ・Table of Contents Plus
    ・TinyMCE Advanced
    ・WordPress Popular Posts
    ・WordPress Related Posts
    ・WP Media Category Management
    ・WP Multibyte Patch
    ・WP SVG Icons

  • #51192 返信

    ぽんちゃん

    こんにちは。

    「EWWW Image Optimizer」は割と最近入れたもので、入れる前から不具合が発生していたので、怪しいのは「Broken Link Checker」かもしれません。

    先日、このように記載しましたが、他のプラグインと勘違いしていました。「EWWW Image Optimizer」も不具合が発生する前から入れていたかもしれません。記憶が曖昧で申し訳ありません。

  • #51211 返信
    わいひら
    わいひら
    キーマスター

    またトピック内では「Broken Link Checkerが怪しい」とのことですが、本日実際にBroken Link Checkerでリンク切れ報告があったので「リンク切れではない」を設定しました。

    このリンク切れ報告自体はSEO設定が消えた記事とは無関係の記事なので関係があるのかどうかはよくわかりません。

    リンク修正した記事と同じであれば可能性は高いのですが、無関係の記事であれば、可能性は低いような気がします。

    現在、#51114#51188で共通しているプラグインは以下ですね。

    ・AddQuicktag
    ・Akismet Anti-Spam (アンチスパム)
    ・Broken Link Checker
    ・Category Order and Taxonomy Terms Order
    ・Contact Form 7
    ・EWWW Image Optimizer
    ・Google XML Sitemaps
    ・PS Auto Sitemap
    ・TinyMCE Advanced
    ・WordPress Popular Posts
    ・WP Multibyte Patch

    ちょっと、これらに絞って、テスト環境でインストールしてみて、不具合が再現するか試してみます。

  • #51212 返信
    わいひら
    わいひら
    キーマスター

    ・SEO設定が消えててなおかつ未修正の記事:
    https://my-turbulence.com/sizuoka-foods

    この記事は、ディスクリプションは設定されているようなんですけど、その後修正等をされたのでしょうか?

  • #51219 返信
    わいひら
    わいひら
    キーマスター

    もう一度、コードを見返していたら、「これはもしかしたら競合問題が起きるかもしれない」という部分を見つけたので、修正してみました。
    https://wp-simplicity.com/wp-content/uploads/2017/03/simplicity2-3.zip
    これで多分大丈夫なのではないかと思います。おそらく。

  • #51220 返信

    ましゅー

    >わいひらさん

    この記事は、ディスクリプションは設定されているようなんですけど、その後修正等をされたのでしょうか?

    この記事のSEO設定は空欄が発覚してから現在まで修正を加えていません。

    ディスクリプションに記載されている内容は「抜粋」のものですね(以前使っていたテーマで抜粋を入力する習慣があったので、そちらがディスクリプションとして生き残ってくれました)。

  • #51243 返信

    ぽんちゃん

    もう一度、コードを見返していたら、「これはもしかしたら競合問題が起きるかもしれない」という部分を見つけたので、修正してみました。
    これで多分大丈夫なのではないかと思います。おそらく。

    ありがとうございます。
    昨夜アップデートしたので、しばらく様子を見てまたご報告させて頂きます。

  • #51245 返信

    hide

    トピック『投稿時のSEO設定について』でコメントを記載したものです。
    先トピックでも返信させていただきましたが、念のためこちらでも返信させていただきます。

    【サイト】
    http://ima-present.com/

    【消えてしまったURL】
    http://ima-present.com/brace308

    【使用中プラグイン】
    BackWPup
    Foo Gallery
    FooBox Image Lightbox
    FooGallery Owl Carousel Template
    Google XML Sitemaps
    Speech bubble (ふきだしプラグイン)
    WP Gallery Custom Links

    新着から5記事目に不具合が起こることが多いです。
    お手数おかけしますが、よろしくお願いします。

  • #51253 返信

    みき

    と言うことは…

    Google XML Sitemaps ?

    ちなみに僕のサイトではこのような現象はおきていません

    あとGoogle XML Sitemapsは使っていません

  • #51254 返信

    みき

    #51219で解決すればよいのですが… (>_<)

  • #51260 返信
    わいひら
    わいひら
    キーマスター

    みなさんありがとうございます。
    情報のおかげで、原因をかなり絞ることができました(もっと腕がよければもっと早くわかったのかもしれませんが;)。
    まだ「どうして不定期に消えるのか?」ということはわかっていませんが、問題部分は何となく分かったような気がします。多分。おそらく。

    僕的には、#51219とかSimplicity2.5.0d以降のアップデートで、おそらく修正されたのではないかと思っています。
    https://wp-simplicity.com/downloads/downloads2/

    hideさんも、よかったら、最新版にアップデートしてみていただければと思います。

  • #51429 返信

    ぽんちゃん

    お世話になっております。

    最新版にアップデートしてから1週間様子を見ていましたが、記事投稿・編集・リンク編集などの作業を行っても同様の不具合が発生することはありませんでした。

    この度は親切に対応して頂き、本当にありがとうございました。感謝致します。

  • #51435 返信
    わいひら
    わいひら
    キーマスター

    ご確認ありがとうございます。
    今のところ、不具合が起きていないようで安心しました。

返信先: SEO設定に入力した内容が消えてしまう
あなたの情報:




スポンサーリンク
アドセンス(大)
アドセンス(大)