「AMP有効」カテゴリーの除外ができない件について

Simplicityの特徴 フォーラム 不具合報告 「AMP有効」カテゴリーの除外ができない件について

このトピックには15件の返信が含まれ、2人の参加者がいます。8 ヶ月、 2 週間前 ki さんが最後の更新を行いました。

  • 投稿者
    投稿
  • #59186 返信

    ki

    お忙しいところ恐れ入ります

    AMPを有効にして、一部のカテゴリのみAMPにしようとしました

    そのため、カテゴリIDを除外の欄にカンマをつけていれたのですが、「AMP除外」になりませんでした

    確認をしようとして、普通のサイトを開くと、AMPボタンが出てきてしまいます

    そして、それをクリックすると、AMPページが出てきてしまいます

    除外カテゴリIDが30個近くあるので、それがいけないのでしょうか

    教示いただければ助かります<m(__)m>

  • #59192 返信
    わいひら
    わいひら
    キーマスター

    どのように除外しているのか、場外入力ボックスに入っているテキストをそのまま貼り付けてもらってよろしいでしょうか?

  • #59193 返信
    わいひら
    わいひら
    キーマスター

    あと、数点質問です。
    カテゴリIDが30個とのことですが、それは一気に入力されたのでしょうか。
    それとも少しずつ登録して行かれたのでしょうか。
    少しずつ登録していたのであれば、登録過程では動作していましたでしょうか。

  • #59198 返信

    ki

    返事遅れました

    除外欄に入れたカテゴリIDは下記の通りです

    また、入れるときには、一気にいれてしまいました

    1,2,4,8,27,37,38,39,40,41,42,43,44,46,47,48,49,50,51,52,54,55,56,91,100,148,372,402,418,422,424,469,558,579,586,587

    よろしくお願いいたします<m(__)m>

  • #59203 返信

    かうたっく

    また、入れるときには、一気にいれてしまいました

    少しずつ登録していたのであれば、登録過程では動作していましたでしょうか。

    1,2,4,8,27,37,38,39,40,41,42,43,44,46,47,48,49,50,51,52,54,55,56,91,100,148,372,402,418,422,424,469,558,579,586,587

    少しずつ登録すれば動作するか、念のため確認いただけますか。

  • #59204 返信

    かうたっく

    1,2,4,8,27,37,38,39,
    40,41,42,43,44,46,47,
    48,49,50,51,52,54,55
    ,56,91,100,148,372,402
    ,418,422,424,469,558,579
    ,586,587

    メモとして。

  • #59209 返信

    ki

    遅くなってしまいました

    今確認したところ、カテゴリIDを1つだけの場合、正常に作動します
    詳細にいうと、除外カテゴリの記事にだけ「AMP」ボタンがでてきませんでした

    ですが、2つ入れると、2つとも「AMP」ボタンが出てきて、除外機能が作動しませんでした

    具体的にいいますと、
    「39」だけいれると、「39」だけ「AMP」できませんでした
    「39,44」といれたところ、両方とも「AMP」ページができました

    報告は以上です

  • #59223 返信
    わいひら
    わいひら
    キーマスター

    ご報告ありがとうございます。
    おかげで、原因を特定し不具合を修正することができたと思います。
    修正したものを以下にアップしておきました。
    https://wp-simplicity.com/wp-content/uploads/2018/03/simplicity2-1.zip
    よろしかったら、試してみていただければ幸いです。

  • #59231 返信

    ki

    早速の対応ありがとうございました

    いただいた新しいテーマを確認したところ、除外カテゴリ以外のカテゴリのページには「AMP]ボタンがでてこなくなりました

    ありがとうございました

    ここで1つ質問させてください

    「AMP」ボタンはなくなりましたが、アドレスに「/?amp=1」を付けると、そのページが表示されました

    ということは、アドレスに「/?amp=1」がついたページが育成されているということですが、そのぺージは「AMP」仕様ではなく、通常表示になっていました

    ということは、サーチコンソールに登録している場合、「AMP」エラーがでるということでしょうか

    知っている限りで結構ですので、お考えをお聞きしたいと思います

    今回は素早い対応ありがとうございました<m(__)m>

  • #59238 返信

    かうたっく

    「AMP」ボタンはなくなりましたが、アドレスに「/?amp=1」を付けると、そのページが表示されました

    ということは、アドレスに「/?amp=1」がついたページが育成されているということですが、そのぺージは「AMP」仕様ではなく、通常表示になっていました

    AMP対応してないのに、アドレス/?amp=1で通常ページが表示されて、AMPの表示ではないってことですか?転送されてる感じではないですよね?

    AMPエラーは出てませんか?テストのリンクでどのようになってるのかなと。

    AMP ページではありません
    この URL は AMP ページではありません。AMP ページへのリンクも設定されていません。

    AMP対応してないページ(noindex環境)で確認した時のメッセージです。

  • #59243 返信

    ki

    かうたっく様へ

    Googleのテストリンクでは、やはり

    AMP ページではありません
    この URL は AMP ページではありません。AMP ページへのリンクも設定されていません。

    とでました

    「/?amp=1」付きのアドレスをいれると、リダイレクトされず通常表示にはなりますが、noindexになっているということなんですね

    合点がいきました
    ありがとうございましたm(_ _)m

  • #59246 返信

    かうたっく

    noindexになっているということなんですね

    AMP対応してないページ(noindex環境)で確認した時のメッセージです。

    テスト環境(indexしていないページ)でしか確認していません。と言う事で、実際のページは確認しないと不明ということです。

  • #59247 返信

    かうたっく

    「AMP」ボタンはなくなりましたが、アドレスに「/?amp=1」を付けると、そのページが表示されました

    ということは、アドレスに「/?amp=1」がついたページが育成されているということですが、そのぺージは「AMP」仕様ではなく、通常表示になっていました

    ということは、サーチコンソールに登録している場合、「AMP」エラーがでるということでしょうか

    私はAMP対応は全くしてませんが、/?amp=1が付いてもアクセスでき、アナリティクスを確認してもアクセスの取得もしているようです。

    AMPページを作成してないので、通常ページを表示してます。私の環境ではサーチコンソールでエラーだと言われてません。

    AMP対応して通常ページを表示しているとエラーは出るって感じですかね。

  • #59249 返信

    ki

    AMPページを作成してないので、通常ページを表示してます。私の環境ではサーチコンソールでエラーだと言われてません。
    AMP対応して通常ページを表示しているとエラーは出るって感じですかね。

    自分もエラーが出ているというわけではなく、エラーになってしまうのかな・・・と思っただけでした
    現在いくつかエラーがでているのですが、時間差でエラーをはきだしているようで、もう少ししないと、現在の状態でエラーかどうかはわからないです
    スミマセン

    私はAMP対応は全くしてませんが、/?amp=1が付いてもアクセスでき、アナリティクスを確認してもアクセスの取得もしているようです。

    えっ・・そうなんですか
    「AMP」を有効にしなくても「/?amp=1」をつけてアクセスできるんですね
    ということは、自分の症状は、全く問題なしということになるような気がします
    もう少し症状をみてみたいと思います

    ありがとうございました<m(__)m>

  • #59282 返信
    わいひら
    わいひら
    キーマスター

    Yahoo!に、「/?amp=1」をつけても問題なく表示されるように、言われるのクエリは、それに対応する処理が書かれていないと、普通に通常ページが表示されます。
    https://www.yahoo.co.jp/?amp=1

    AMPページがGoogleに認知されるには、ページのソースコードに「AMPがあるよ」的なタグが書かれていないと、反映されません。
    AMPが無効になっていると、そのタグが出力されないので、GoogleはAMPページを認識しないようになっています。

  • #59526 返信

    ki

    わいひら様へ

    返事が大変遅れてしまいました

    なるほど、理解しました

    フォローありがとうございましたm(__)m

返信先: 「AMP有効」カテゴリーの除外ができない件について
あなたの情報:




スポンサーリンク
アドセンス(大)
アドセンス(大)