ライブレスポンシブプレビュー機能が使えなくなっている

Simplicityの特徴 フォーラム 不具合報告 ライブレスポンシブプレビュー機能が使えなくなっている

18件の返信スレッドを表示中
  • 投稿者
    投稿
    • #50840 返信
      持永
      ゲスト

      カスタマイズ画面でほかのテーマでは起こらないのですがsimplicity2だけ
      ライブレスポンシブプレビュー機能が使えなくなっています。

      プラグインをすべて外してみたりキャッシュを削除したりしているのですが治りません

      初めてのテーマだけにいつもお世話になっております。
      ぜひ対応お願いいたします。

      http://motinaga.com/

    • #50867 返信
      わいひらわいひら
      キーマスター

      現在ご利用されているブラウザは何でしょうか。
      利用中のブラウザ以外でも動作しなかったでしょうか。

    • #50877 返信
      角笛あき
      ゲスト

      お世話になっております。
      同様の現象が出ていますが、少々戸惑っております。

      現在2サイトを同時に編集しております。環境は

      ・wp4.7.3
      ・simplicity2.4.0i
      ・ブラウザFireFox51.0.1(64bit)

      となっております。一つは昨日ドメインを取得し新規にインストールしました。もう一つは1週間ほど前に同様に新規ドメイン取得→WPセットアップを実施しました。

      昨日インストールした方は、ライブレスポンシブプレビューが効いています。ところが先週セットアップした方は「コンテンツセキュリティポリシーによりブロックされました」と表示されます。ちなみにサーバーはCoreserverで、どちらも同じサーバーに載っています。

      不可解です・・・

    • #50895 返信
      わいひらわいひら
      キーマスター

      #50867でも書いていますが、他のブラウザでは動作するのでしょうか?

    • #50899 返信
      みき
      ゲスト

      コンテンツセキュリティポリシーによりブロックされました
      の問題は今まで何度かフォーラムでも投稿がありました

      すべてFirefoxで起こっているので一度ブラウザを変更してみてください
      ↑と言うかFirefoxの警告だと思います

      あと念のためFirefoxを最新版の52にしてみてください

    • #50913 返信
      持永
      ゲスト

      連絡遅くなってしまい申し訳ありません

      Firefox、Google Chrome、Internet Explorerなどで試したのですがダメでした

    • #50920 返信
      角笛あき
      ゲスト

      Chromeだと両方のサイトともライブレスポンシブプレビューが動作しました。
      Firefoxについては、最新にしてもダメでした。

    • #50921 返信
      わいひらわいひら
      キーマスター

      一応、問題の切り分けとして、他のテーマでは、プレビュー画面は表示されるのでしょうか?

      一応、過去に投稿された、同様の問題が出るトピックも掲載しておきます。
      新規投稿時、1カラム本文のみで保存してもデフォルト投稿になります
      FireFoxでカスタマイズのプレビュー画面が表示されません

      ただ、過去のものは、いずれもFirefoxのみで起きているものなので、また違った原因なのかもしれません。
      全てのブラウザで起きることであれば、プラグインとかが原因の可能性が高いのですが、全て停止して試してみられたんですよね?

    • #50922 返信
      わいひらわいひら
      キーマスター

      書き込んでいるうちに返信が。
      #50921は、#50913に対しての返信です。

    • #50923 返信
      わいひらわいひら
      キーマスター

      #50920
      ここなんかを見る限り、スクリプトが影響しているとかかもしれません。
      Content Security Policy (CSP) – Web セキュリティ | MDN

      アドオンとかが原因の可能性も考えられるので、アドオンが何も入っていない一度まっさらなFirefox系ブラウザで動作するかを試していただければと思います。

    • #51047 返信
      持永
      ゲスト

      連絡遅れてしまって申し訳ありません

      ほかのテーマではライブレスポンシブプレビュー機能は使えていますが
      simplicity2だけこの機能が使えずにカスタマイズ画面でモバイル表示の大きさが変わるだけでになっています。

      どうしてもsimplicity2で作りたくてサイトを初期化して初めて見ましたが治りませんでした

      これはどうしようもないことなのでしょうか?

    • #51053 返信
      みき
      ゲスト

      テーマには問題なさそうなんですけどね…
      プラグインでもないとするとサーバー、アドオンあたりでしょうか

      サーバーはどちらをご利用でしょうか?
      xserver、mixhostは問題なさそうですが
      (わいひらさんが利用されているので問題ないかと)

    • #51057 返信
      わいひらわいひら
      キーマスター

      #51047
      他のテーマで利用できているということは、Simplicity由来の可能性もあるのかもしれません。
      ただ、僕の環境では、そういった問題は出たことがないんですよね。
      なので、テーマ+(アドオン or サーバー)に依存するエラーなのかも。
      でも、エラーメッセージでググっても解決方法らしい解決方法が出てこないんですよね^^;

      一応、不具合をまとめるためにも、もう一度確認なんですが、現在の状態は以下のようになっているということですよね?

      ・Simplicityでのライブレスポンシブでコンテンツセキュリティポリシーによりブロックされました」と表示
      ・Firefox、Chrome、IEでも同様にコンテンツセキュリティポリシーエラーが出る
      ・全てのプラグインを停止しても全てのブラウザでエラーが出る
      ・アドオンなどをインストールしていないブラウザ(Firefoxのポータブル版など)でもエラーが出る

      あと、よろしければサーバー教えていただければと思います。

    • #51063 返信
      キュウリ
      ゲスト

      xwpなどは一部機能を制限してるので、その原因もあるかもしれませんね。
      それによって作動しないプラグインもあったりしますし。

    • #51066 返信
      Hidekichi
      ゲスト

      ライブレスポンシブプレビューの時にデベロッパーツールのコンソールにエラーは出てませんか?

    • #53949 返信
      ゲスト

      お世話になっております。私も同様の現象に悩まされております。

      ・カスタマイザーで、ライブプレビューが機能しない(左側メニューからスキンなど設定を変更しても、右側のプレビューは何も変わらない)
      ・「保存して公開」をクリックすると「保存しました」と表示されるが、実は保存されていない

      ■試したこと
      ・プラグイン全部停止
      ・ブラウザのキャッシュの削除
      ・ブラウザのプライベートウィンドウでの設定変更
      ・子テーマの再インストール
      ・Chrome、Safariなど複数のブラウザで試してみる
      ・Chromeのデベロッパーツールでのエラー確認→エラーなし
      ・サーバーでWAFを停止する

      上記ですべて改善せずでした。
      なお、他のテーマですとカスタマイザーは問題なく機能します。

      ■環境
      WordPress 4.8
      Simplicity 2.5.7 + 子テーマ simplicity2-child20161002a
      Mixhost(jp8サーバー)
      PHP 7.1
      https化しております

      いろいろ試しておりますが問題の切り分けが出来ません。他に原因究明のために試せることはありますでしょうか?

    • #53977 返信
      わいひらわいひら
      キーマスター

      とりあえず、PHPは7.0にしてみてください。
      僕の場合、このbbPress Forumが7.1で不具合を起こしたので、当サイトも7.0で利用しています。
      もしかしたら7.1だと正常動作しないコード等があるのかもしれません。

      ライブプレビューの報告のあった不具合で圧倒的に多いのは、やっぱりプラグインです。
      あと、ボタンが動作しない原因の多くは、ブラウザキャッシュでした。
      ただ、どちらも試されているようですし、正直今のところ原因は思い当たりません。
      僕も、Mixhost(jp8サーバー)でSimplicityを利用しているのですが、全く問題なくライブプレビュー機能が使えています。
      違いと言ったら、PHPのバージョンくらいでしょうか。

    • #53982 返信
      ゲスト

      御連絡ありがとうございます。
      おっしゃられたようにPHP7.0にしてみましたが、状況変わらずでした。

      そしていろいろと原因探ってみて1つ改善方法を見つけました。カスタマイザー内で設定を変更後に、右側のプレビューからどこか内部リンクをクリックして遷移すると、設定が反映されているのです。

      このまま「保存して公開」を押すと、変更した設定が問題なく保存されているようです。PHP7.1でも問題なしです。

      再びいろいろ探ってみて、原因など判明したら再度書き込み致します。わいひら様、いつもありがとうございます。

    • #53984 返信
      わいひらわいひら
      キーマスター

      ご確認ありがとうございます。
      PHPのバージョンは問題ないということがわかり安心しました。
      ただ、以下の状態は、なおさら謎な状態になってしまいました^^;

      カスタマイザー内で設定を変更後に、右側のプレビューからどこか内部リンクをクリックして遷移すると、設定が反映されているのです。

      とりあえず、設定が保存できるということなので、利用はできそうなので少し安心です。
      僕も、今後暫く、テーマカスタマイザーの動作を注意して見てみたいと思います。

18件の返信スレッドを表示中
返信先: ライブレスポンシブプレビュー機能が使えなくなっている
あなたの情報:




スポンサーリンク
アドセンス(大)
アドセンス(大)