モバイルメニュー(デフォルト)が表示されなくなった

Simplicityの特徴 フォーラム 不具合報告 モバイルメニュー(デフォルト)が表示されなくなった

このトピックには6件の返信が含まれ、1人の参加者がいます。1 年、 1 ヶ月前 cragycloud さんが最後の更新を行いました。

  • 投稿者
    投稿
  • #59467

    cragycloud

    これまでモバイルメニューをデフォルトにしていました。

    しかし気がついたときには、ハンバーガーのようなアイコンは表示されていますが、肝心のメニューがトップしか表示されなくなっていました。キャッシュも削除しましたが変わりませんでした。なぜなのか、わかりません。

    現在は、アコーディオンツリーにしていますが、これはきちんとメニューのすべてが表示されています。ほかにはスライドもおなじく表示されています。

    ちなみに、この症状がでる前にカスタマイズしたのは、サイドバーを336pxにしています。関係あるかどうかわかりませんが、一応お知らせいたします。

    当該サイトは以下のとおりです。
    https://cragycloud.com/

  • #59470

    Akira

    私のテスト環境では問題なく表示されるので、 Simplicity の不具合とは考えにくいです。

    「アコーディオン(デフォルト)」が有効化されている状態を見ないと、原因と解決方法が分かりません。

  • #59471

    cragycloud

    ありがとうございます。

    アコーディンツリーにしていました。失礼しました。

    ご指摘があったので、モバイルメニューをデフォルトにもどしました。
    当方の環境では、やはりトップ(ホーム)しか表示されません。

    どのように修正したらいいのか教えていただけると幸いです。
    よろしくお願いいたします。

  • #59472

    cragycloud

    追記いたします。

    不具合がでる直近にもうひつカスタマイズをしていました。
    グローバルメニューの高さを変更しました。

    プラグインは停止してチェック、キャッシュも削除しました。

    よろしくお願いいたします。

  • #59473

    かうたっく

    全く問題なくハンバーガーメニューが表示されてますよ。

    https://gyazo.com/0a9c73b5d17b5c0ee64467c777147118

    メニューの中にはトップと入ってるのも確認できましたし。

  • #59474

    Akira

    子テーマの以下の CSS が原因です。

    #navi ul {
      height: 38px; 
    }

    この指定で、グローバルメニュー全体の高さが 38px になっています。

    各メニューの高さを 38px にする場合には、以下の CSS をお使いください。

    #navi ul > li {
      height: 38px;
    }
  • #59475

    cragycloud

    akiraさん、かうんたっくさん、ご指導ありがとうございました。

    akiraさんのご指摘どおり修正したところ見事に治りました。

    お手数をお掛けしました。重ねてお礼を申し上げます。

トピック「モバイルメニュー(デフォルト)が表示されなくなった」への新規返信追加は締め切られています。

スポンサーリンク
アドセンス(大)
アドセンス(大)