デバッグログ

Simplicityの特徴 フォーラム 不具合報告 デバッグログ

このトピックには13件の返信が含まれ、2人の参加者がいます。9 ヶ月、 1 週前 まさ さんが最後の更新を行いました。

  • 投稿者
    投稿
  • #59172

    まさ

    いつもお世話になっております。

    デバッグログを確認したところ、
    wp-content/themes/simplicity2/lib/mobile.php on line 33
    が表示されていたのでご報告いたします。

  • #59180

    まさ

    すいません。
    お騒がせしました。

    原因はプラグインの「Category Order」だと思われます。「Category Order」を削除して、代わりに「Category Order and Taxonomy Terms Order」を有効化して、しばらく様子を見ようと思います。

  • #59183

    まさ

    こんにちは。
    プラグインを全て停止にしてもダメでした。

    原因がよくわからないので「Debug Bar/Debug-Bar-Extender」をインストール・有効化して確認してみました。

    「Debug-Bar-Extender」の「Variable Lookup」の場所で下記のような記述があったのですが、何か関係ありそうですかね。

    template via get_template[1] (19.00 b)
    
    called by trace_var_template() in /wp-content/plugins/debug-bar-extender/debug-bar-extender.php::L368 initiated from apply_filters() in /wp-includes/class-wp-hook.php::L286 
    0 ( 19.00 b )
    
    template via get_template = 'simplicity2'
    
    Note: you can screen additional variables via Debug_Bar_Extender::instance()->trace_var( $value, $var_name = false ) or simply by using dbgx_trace_var( $value, $var_name = false ). Omitting the $var_name will let the script look it up. Please be aware that sizes are approximate based on strlen(serialize())

    サイト:https://iyasidouga.hp-joho.net/

  • #59185

    まさ

    デバッグでは下記が表示されています。

    PHP Notice: Undefined index: HTTP_USER_AGENT in /wp-content/themes/simplicity2/lib/mobile.php on line 33

    よろしくお願いします。

  • #59188
    わいひら
    わいひら
    キーマスター

    /lib/mobile.phpの33行目でその警告が出るのは、以下が原因かと思います。
    $_SERVER['HTTP_USER_AGENT']
    ただこれは、サーバーのユーザーエージェント(ブラウザ情報等)が挿入される配列です。
    通常は、必ずユーザーエージェントは挿入されると思うのですが、まささんは、どのようなサーバーやブラウザを利用されているのでしょうか?
    どういった環境だとHTTP_USER_AGENTが設定されないのか、後学のため教えていただければ幸いです。

  • #59189
    わいひら
    わいひら
    キーマスター

    すいません、サイトのURLを見逃していました;
    サーバーはエックスサーバーのようですね。
    エックスサーバーでそのような警告メッセージが出るのなら、でないように修正しておこうと思います。

  • #59191
    わいひら
    わいひら
    キーマスター

    一応、修正したので修正したものをアップしておきます。
    https://wp-simplicity.com/wp-content/uploads/2018/03/simplicity2.zip
    よろしければ、お試しいただけると幸いです。

  • #59195

    まさ

    わいひらさん
    ありがとうございます。

    デバッグモードにして1時間放置してみて、警告が出なかったので大丈夫だと思います。

    もう一つ聞いてもいいですか?

    404で表示されている下記ページが、
    https://carp.hp-joho.net/archives/3194?amp=1
    Google Search Console で「サーバーエラー(5xx)」と指摘されました。

    デバッグモードで確認したところ
    PHP Notice: Trying to get property of non-object in /wp-includes/link-template.php on line 643
    と表記されていました。
    プラグインを全部停止するなど試してみましたが、ダメでした。
    どうすればよいのか、もしわかればご教授願いたいです。

    今回の件といい、2月14日からエラーが出てるのでサーバー側に障害が起きてるってことはないですかね。

  • #59219
    わいひら
    わいひら
    キーマスター

    ご確認ありがとうございます!

    ただ以下の場所は、Wordpressのコアファイル部分なので、ちょっとわからないです。
    /wp-includes/link-template.php

    テーマ内での警告なら、わかるとは思うのですが。
    こちらのローカル環境で、404ページを出しても、同様の警告が出ないので、警告の再現方法が分からないと、ちょっと何ともできないかもしれません。

  • #59226

    まさ

    本当に有難うございました。
    もう一度、プラグインを念入りにチェックしてみます。

  • #59234

    かうたっく

    今回の件といい、2月14日からエラーが出てるのでサーバー側に障害が起きてるってことはないですかね。

    2月14日に何かを行ったなどはないですか?何らかの更新や復元などです。原因の可能性が膨大でも原因を切り分けて可能性を潰して、残ったものが原因としか言えないかもしれません。※プラグイン以外にも原因があるかと思います。

  • #59242

    まさ

    かうたっくさん
    有難うございます。

    WPの再アップデート、Simplicityの再インストール、14日前後で更新したプラグインを以前のものに戻して再インストール、そして全プラグインを停止して確認。

    それでもダメだったので、WP消去してデータベースから復旧させました。

    ブログの表示自体はどこもおかしくないのですが…、エラーが表に出てこないので箇所特定が困難です。

    上記ページ以外今のところ表示自体には問題はないので、地道にエラー箇所を探していきます。

    かうたっくさんもわいひらさんも、有難う♪

  • #59248

    かうたっく

    エラーコードを丸々検索したら、?/feed=rss2&pageと言うアドレスが目立つんで、feed系の何かみたいですね?

    /wp-includes/link-template.php on line 643

    この辺りのコードの{から}までを翻訳したら

    / **
     *投稿コメントフィードのパーマリンクを取得します。
     *
     * @since 2.2.0
     *
     * @param int $ post_idオプション。投稿ID。デフォルトはグローバル <code>$ post</code>のIDです。
     * @param string $ feedオプション。フィードの種類。デフォルトは空です。
     * @return string指定された投稿のコメントフィードのパーマリンク。
     * /
    / **
    *投稿コメントフィードのパーマリンクをフィルタリングします。
    *
    * @since 1.5.1
    *
    * @param string $ urlコメントを投稿フィードpermalink。
    * /

    この関連かもしれないですね?

  • #59251

    まさ

    かうたっくさん
    有難うございます。

    feed系は心当たりがないです。

    でも不思議なエラーですよね!
    1ページだけのエラー、それも削除したはずのページがエラーになるなんて…。
    下記のページ以外はちゃんとインデックスされているし、その他のAMPページも404ページも正常にインデックスされてますから。

    https://carp.hp-joho.net/archives/3194?amp=1
    「サーバーエラー(5xx)」はAMPページなのか、404ページなのかも検討がつきませんし。(404ページにはnoindexがあるからAMPページがエラーになるのかな。)

    たちまち緊急性を要することはないので、見逃したものはないか、一つずつ確認していきます。
    WPとSimplicityは今のところ問題なしと考えています。この際だから、プラグインも整理してスッキリさせようと思っています。最悪の場合は、全プラグインを削除して要るものだけを再インストールします!

    有難うございました。

トピック「デバッグログ」への新規返信追加は締め切られています。

スポンサーリンク
アドセンス(大)
アドセンス(大)